ealtmayer
ealtmayer

Hello all,

While I was doing some maintenance on my website, I noticed I couldn't write any new files in the assets folder but I can still create folder as usual. I checked my ftp and all the folders ave the permission 777. It was working fine before and the only thing I changed was updating the CMS to the latest version.

The error message I get is this one: Error saving file 'random.css'. Please check write permissions.

Any idea?

Last updated

ealtmayer
ealtmayer

I'll add that I can create files everywhere else. Partials, Pages, Layouts etc... everything works but those damn files in the assets section.

edit: I can create files directly from the ftp, and then I can save them directly through the backend.

edit 2: I tried to rename the files I created from my ftp. I got this error code instead of the previous one: Error creating directory . Please check write permissions.

Last updated

Vladimir
LukeTowers
LukeTowers

You'll actually want the changes from https://github.com/octobercms/october/commit/3a1f547adb0bef8245691fc5df0612cf865d90d7 and https://github.com/octobercms/library/commit/5feb7b872f2ab4e1e09b7980b61b2d7048d3fc17 to fix the issue properly.

These will be included in the next build, Build 469

ealtmayer
ealtmayer

Amazing, thanks

hendrik.erz33643
hendrik.erz33643

Heya,

I'm afraid I have to ask further, as with build 469 this does not work for me. Here's what I have tested so far:

  • Setting the CHMOD in the cms.php to 777, 764, 744, 755 and 775 as well as "null" (according to the current cms.php in the master branch of the GitHub repo)
  • Setting chmod on the assets-directory to anything from 744 to 777.

It is most certainly not a permissions issue. Furthermore I found out that the creation CHMOD 777 is hard-coded in the class, so I'm not sure if that's intended as well …?

This is happening both on a fresh wizard-install (about 4 weeks old) since the beginning as well as on an older but fully updated install (about 4 years old), before I began tampering with the configuration and directory permissions.

LukeTowers
LukeTowers

Try updating to v1.1 via composer

rupert24306
rupert24306

LukeTowers said:

Try updating to v1.1 via composer

I am still having this problem with build 469 and not sure how to update to v1.1 or even what needs updating. Any help very much appreciated

mjauvin
mjauvin

Try the composer install, that'll install 1.1 by default. Don't forget to set disableCoreUpdates to true in config/cms.php

https://octobercms.com/docs/console/commands#console-install-composer

LukeTowers
LukeTowers

And note that the version number reported by the backend is currently inaccurate

rupert24306
rupert24306

Unfortunately for one site I manage I do not have console access. Is there another fix for this?

-- oh, I found a solution -- just add files through FTP.

Last updated

1-11 of 11