This forum has moved to a new location and is in read-only mode. Please visit talk.octobercms.com to access the new location.

JimRed
JimRed

Dear All,

Is it recommended to install new (L6) version of OctoberCMS (v1.1.x) for production projects?
What is the current status of this version/development? It was announced months ago and it can be installed by CLI commands but GUI installer still support previous version only. What is the reason behind it, do you know details?

Thanks,
Jim

oskar.villani40843
oskar.villani40843

JimRed said:

Dear All,

Is it recommended to install new (L6) version of OctoberCMS (v1.1.x) for production projects?
What is the current status of this version/development? It was announced months ago and it can be installed by CLI commands but GUI installer still support previous version only. What is the reason behind it, do you know details?

Thanks,
Jim

Yep, I am curious too... But unfortunately there is few information.

Just for the sake of self-marketing the october team should be much more communicative, from my point of view.

The more I dig in this project, the more I see the huge potential and opportunities it has. Most of them still concealed, sort of.

Anyway, as far as I am understanding the communication V1.1 is not ready for production at the moment.

mjauvin
mjauvin

1.1 is definitely recommended for production. 1.0 is now a legacy branch and only security updates will be released.

The reason for the marketplace still using the 1.0 branch is that some work needs to be done for the new branch to be offered and the marketplace maintainers are quite busy at the moment.

oskar.villani40843
oskar.villani40843

mjauvin said:

1.1 is definitely recommended for production. 1.0 is now a legacy branch and only security updates will be released.

The reason for the marketplace still using the 1.0 branch is that some work needs to be done for the new branch to be offered and the marketplace maintainers are quite busy at the moment.

:) :) :)

That's great news!

Any suggestion to find a summary what has still to be done and may affect an existing installation or custom made plugins?

BennoThommo
BennoThommo

@JimRed @oskar.villani40843

You can find details on what you need to look out for when upgrading to version 1.1.0-1.1.1 here: https://octobercms.com/support/article/rn-11

1-5 of 5

You cannot edit posts or make replies: the forum has moved to talk.octobercms.com.