eduguimara1591
eduguimara1591

Im using Ubuntu 12.04, my mod_rewrite is set and my .htaccess.october is configured, but my backend have no style at all
captura de tela de 2014-06-06 18 29 53
I tried everything, my virtualhost is set to "AllowOverride All", my htaccess is configured "RewriteBase / " and "RewriteBase /october/ " and it still not works.

mickburkesnr
malcolm4745
malcolm4745

Installation of Fedora 20 also initially had the same issue, which looks like a mod_rewrite problem. I did this using the install php approach, getting the dependencies as recommended and setting up the DB (MariaDB in Fedora's case.

I've done the following:

  1. from the base directory for OctoberCMS

    sudo chown -R root:apache app/storage

    sudo chown -R root:apache themes

    sudo chown -R root:apache uploads

    sudo chmod -R 775 app/storage/

    sudo chmod -R 775 themes

    sudo chmod -R 775 uploads

I have the following entry in httpd.conf (/etc/httpd/conf/httpd.conf in Fedora)

<VirtualHost *:80>
   ServerAdmin malcolm@bwlch.net
    DocumentRoot /var/www/october
    ServerName october.localdomain
    ErrorLog logs/october-error_log
    CustomLog logs/october-access_log common
    Options Indexes FollowSymLinks
    <Directory "/var/www/october/">
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
    </Directory>
</VirtualHost>

The local .htaccess files weren't an issue, as are most the items covered in the article above, as they are dealt with via yum during the installation of the dependencies

Last updated

keith4220
keith4220

Hi, I'm getting the same issue and have tried everything I can find here and on other sites. Nothing works. Only putting index.php at the end will give me the styling on the front-end and access to the backend (by appending /backend). I just installed the new version of OctoberCMS and ported across the old theme. I can see that it looks fine when I use index.php but otherwise all the styles are gone. Is there any update or new fixes relating to the new version.? Everything that was advised above I've tried.

thanks guys

signup7819
signup7819

Had this problem (amongst others) installing on Mac OSX Yosemite. I fixed it by uncommenting these 2 lines in my httpd.conf file within my /apache2/ install:
LoadModule rewrite_module libexec/apache2/mod_rewrite.so
LoadModule php5_module libexec/apache2/libphp5.so


and in the same file under <Directory "/Library/WebServer/Documents">
AllowOverride All

Hope this helps someone.

Last updated

Astucieux
Astucieux

Hello to all, I'm running the same problem. I'm under Windows 7, using NginX with WT-NMT. Can anyone help me ? Thanx by advance... Here are my Nginx configs :


worker_processes  1;

events {
    worker_connections  1024;
}

http {

    server_tokens   off;
    # used to ‘copy data between one file descriptor and another‘
    # LE METTRE A OFF pour eviter les pb de cache avec Vagrant ou Virtual Box !!
    sendfile        on;
    tcp_nopush      on;
    tcp_nodelay     on;
    ssi         off;

    #Timeouts
        client_body_timeout 5;
        client_header_timeout   5;
        keepalive_timeout   25 25;
        send_timeout        15s;
    resolver_timeout    3s;

    #Directive sets timeout period for connection with FastCGI-server. It should be noted that this value can't exceed 75 seconds. 
    # 5 par defaut
    fastcgi_connect_timeout 60s;

    #Directive sets the amount of time for upstream to wait for a fastcgi process to send data. Change this directive if you have long running fastcgi processes that do not produce output until they have finished processing. If you are seeing an upstream timed out error in the error log, then increase this parameter to something more appropriate. 
    # 40s par defaut
    fastcgi_read_timeout    60s;

    #Directive specifies request timeout to the server. The timeout is calculated between two write operations, not for the whole request. If no data have been written during this period then serve closes the connection.
    # 15s par defaut
    fastcgi_send_timeout    120s;

    fastcgi_buffers 8 32k;
    fastcgi_buffer_size 32k;
    #fastcgi_busy_buffers_size 256k;
    #fastcgi_temp_file_write_size 256k;

    # Pour gonfler la config :
        #   fastcgi_buffers 16 256K;
        #   fastcgi_buffer_size 256k; 
        #   fastcgi_busy_buffers_size 512k; 
        #   fastcgi_temp_file_write_size 512K;

    open_file_cache off;

    #php max upload limit cannot be larger than this       
    client_max_body_size 8m;
        ####client_body_buffer_size  1K;
        client_header_buffer_size 1k;
        # pour eviter l erreur 400 (bad request header or cookie too large) gonfler ici à 4 32k
        # sachant que la valeur initiale est de 2 1k
        large_client_header_buffers 4 32k;  
    types_hash_max_size 2048;

    include nginx.mimetypes.conf;
    default_type text/html;

    ##
    # Logging Settings
    ##
    access_log "c:/WT-NMP/log/nginx_access.log";
    error_log "c:/WT-NMP/log/nginx_error.log" warn; #debug or warn
    log_not_found on;  #enables or disables messages in error_log about files not found on disk. 
    rewrite_log off;

    #Leave this off
    fastcgi_intercept_errors off;

    gzip  off;

    index  index.php index.htm index.html;

    server {
        listen      127.0.0.1:80    default_server;
        #listen     [::1]:80    ipv6only=on;
        server_name  localhost;

        root "c:/WT-NMP/www/";
        autoindex on;

        allow       127.0.0.1;
        deny        all;

        # deny access to .htaccess files, if Apache's document root concurs with nginx's one
        #
        location ~ /\.ht {
            deny  all;
        }

        #tools are now served from WT-NMP/include/tools/
        location ~ ^/tools/.*\.php$ {                   
            root "c:/WT-NMP/include";
            try_files $uri =404; 
            include     nginx.fastcgi.conf;
            fastcgi_pass    php_farm;
        }
        location ~ ^/tools/ {
            root "c:/WT-NMP/include";
        }

        # Fichiers PHP classiques
        location ~ \.php$ {
            # ajout tanguy
            fastcgi_intercept_errors on;

            try_files $uri =404; 
            fastcgi_pass    php_farm;

            include     nginx.fastcgi.conf;
            }

    }

    # Configurations des projets
    include domains.d/*.conf;
    # Autre fichier de configuration
    include nginx.phpfarm.conf;

}

And my project config is :

server {
    listen      127.0.0.1:80;
    server_name     october.local;
    root    "c:/wt-nmp/www/october";
    autoindex on;

    ## Access Restrictions
    allow       127.0.0.1;
    deny        all;

        access_log "c:/wt-nmp/log/october.access.log";
        error_log "c:/wt-nmp/log/october.error.log";

    location ~ \.php$ {
        try_files $uri =404;
        include     nginx.fastcgi.conf;
        fastcgi_pass    php_farm;
    }

    location / {
        # First attempt to serve request as file, then
        # as directory, then fall back to index.php
        try_files $uri $uri/ /index.php$is_args$args;
    }

    rewrite ^themes/.*/(layouts|pages|partials)/.*.htm /index.php break;
    rewrite ^uploads/protected/.* /index.php break;
    rewrite ^bootstrap/.* /index.php break;
    rewrite ^config/.* /index.php break;
    rewrite ^vendor/.* /index.php break;
    rewrite ^storage/cms/.* /index.php break;
    rewrite ^storage/logs/.* /index.php break;
    rewrite ^storage/temp/.* /index.php break;
    rewrite ^storage/framework/.* /index.php break;
}
DigitalMachinist
DigitalMachinist

Reposting from this thread in case this helps anyone having this issue for the first time and who just found this thread. I've included a curated list of discussion threads for similar issues at the bottom.


In my case, my Apache server's mod_rewrite was disabled. I had to reinstall my WAMP stack to get a more recent version of PHP before installing October, so my previous settings must have been lost.

This is just a matter of adding a line or uncommenting a line (usually at the bottom) of your Apache httpd.conf file like so:

LoadModule rewrite_module modules/mod_rewrite.so

Just search for that line. If it's missing, add it. If it's not, uncomment it. If it's uncommented and you still have these symptoms, look to the links below for other potential problems.

Make sure to restart your apache webserver after the change or nothing will happen!

Since it took me a while to discover this solution, I figured I'd post links to all of the many discussion threads I've now have open in my browser that cover problems resulting in similar symptoms (the 1st one links to the Laravel docs that ultimately fixed my problem):

Last updated

yozie.dev16383
yozie.dev16383

I installed octobercms on a virtual host and is working well after installation, but when I open http://october.app/backend link it displays a 404 error: "The requested URL /backend was not found on this server".

My mod_rewrite is enabled, I changed to "AllowOverride All" in my virtual host and I uncommented the "RewriteBase / " in my .htaccess

Am I missing something? Can someone please help me?

ogoy17590
ogoy17590

How I fixed this after enabling mod_overwrite which still did not work...

In my Apache settings I did not see the second Directory directive in httpd.conf, to modify AllowOverride from None to All.

I changed it in first instance which was <Directory / >, but not the explicit one for my htdocs folder, which had a lot of comments in-between the lines and since I was using notepad I missed it and spent hours trying to figure out what's wrong.

So in the end the only two things I had to do running on Apache 2.4.23 compiled by ApacheHaus.

  1. Enable mod_overwrite.
  2. Add AllowOverride All to Directory in httpd.conf

<Directory "${SRVROOT}/htdocs"> AllowOverride All <Directory / >

koorosh13hm16957
koorosh13hm16957

Thank you Nathan. It did perfectly work for me. You saved my day.

sergio21879
sergio21879

I ran into this same exact problem today and can't believe no one has mentioned IIS.

Here is the web.config file that will fix the issue on Windows with IIS:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <rewrite>
          <rules>
            <rule name="Rule 1" stopProcessing="true">
              <match url="^(.*)/$" ignoreCase="false" />
              <action type="Redirect" redirectType="Permanent" url="/{R:1}" />
            </rule>
            <rule name="Rule 2" stopProcessing="true">
              <match url="^" ignoreCase="false" />
              <conditions>
                <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
                <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
              </conditions>
              <action type="Rewrite" url="index.php" />
            </rule>
          </rules>
        </rewrite>
    </system.webServer>
</configuration>

Last updated

info14532
info14532

How I fixed this on Mac

I wasted enough time playing around with MAMP, Homestead and Vagrant.

After I discovered Valet and I was able to install October locally in about 10 minutes. This helpful Install October CMS on local guide has detailed instructions.

Last updated

enok
enok

Just incase anyone has encountered this issue with www not properly loading css in Nginx I've had this issue where Nginx wouldn't load the www version of my site, it would return a 404. So after search hours online, I found my fix: https://www.digitalocean.com/community/questions/adding-www-to-my-domain-at-nginx-server

by simply adding the www.mydomain.com to the current site-enabled configuration

server {
 listen 80;
 server_name mydomain.com www.mydomain.com;
...

It finally worked!! loaded my css and images etc...

imaduom34200
imaduom34200

i found the solution by just putting an empty text file in "project_directory\storage\cms\combiner.

Last updated

21-34 of 34