j.essenziale236
j.essenziale236

Hi,

I'm having some issues in installing october on my webserver: the installation process seems to work properly, all dependencies seems to be satisfied, but when installation finished I get a non-styled page in the frontend and a 404 error for the backend...

I'm working with a basic LAMP server on Ubuntu 14:04, PHP Version: 5.5.9.

nesste
nesste

The same here

sndan1410279
sndan1410279

Turn on the php_rewrite extension if did not work try to put index.php at the end of the URL

mdgriffin064299
mdgriffin064299

I'm experiencing the same issues, I have the rewrite module turned on. Putting index.php at the start of the url fixes the front end, but all admin resources are returned as 404 pages.

Last updated

coderyeti
coderyeti

try changing r-w-x rules for app/storage/combiner folder.

that worked for me for frontend.

sndan1410279
sndan1410279

Put it like index. php/backend Backend will work on chrome as it was the only browser that work for me.. Firefox was loading the page then give me some communication rest error

Silver Paladin
Silver Paladin

Ran this on windows lamp stack. anything with the prefix in the url of modules results in 404. Mod rewrite is enabled and allow override is set to all for the directory.

sndan1410279
sndan1410279

if you open it on chrome is it OK .... if so update the core to the build 75 and everything will be OK

j.essenziale236
j.essenziale236

Thank you... enabling rewrite module worked for me! For those still having problems even after enabling the mode with a2enmod rewrite, check your: /etc/apache2/sites-available/000-default.conf file and make sure you have the following code in it!

< Directory "/var/www/html" >
    AllowOverride All
< /Directory >

where "/var/www/html" is your webserver root

Last updated

mdgriffin064299
mdgriffin064299

Running the site through a virtual host fixed it for me.

mattjgagnon451
mattjgagnon451

I had the same issue with same setup as the OP. Enabling mod_rewrite solved it perfectly. Looks good so far! Great job guys!

nathan.wienand727
nathan.wienand727

Hi Guys

The solution for me was:

  1. Make sure mod_rewrite is enabled
  2. Uncomment line 12 in the .htaccess file in your site root. "RewriteBase /"

That did the trick for me- fixes all styling issues and url pathing. Good luck everyone!

kuroski
kuroski

Found the solution (I'm sorry, but my English is very bad). If you guys look at the Laravel documentation, you will find the answer: here

Basically in the root directory, modify the .htaccess using code that the documentation provides. And then type the address of your application: http://localhost/october (http://www.path-to-october.com)

Here's my .htaccess as an example: `

<IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
        Options -MultiViews
    </IfModule>
    #### I MODIFIED HERE!!!
    Options +FollowSymLinks
    RewriteEngine On

    ##
    ## You may need to uncomment the following line for some hosting environments,
    ## if you have installed to a subdirectory, enter the name here also.
    ##
    # RewriteBase /

    ##
    ## Black list protected files
    ##
    RewriteRule themes/.*/(layouts|pages|partials)/.*.htm index.php [L,NC]
    RewriteRule uploads/protected/.* index.php [L,NC]

    ##
    ## White listed folders and files
    ##
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteCond %{REQUEST_URI} !\.js
    RewriteCond %{REQUEST_URI} !\.ico
    RewriteCond %{REQUEST_URI} !\.jpg
    RewriteCond %{REQUEST_URI} !\.jpeg
    RewriteCond %{REQUEST_URI} !\.gif
    RewriteCond %{REQUEST_URI} !\.css
    RewriteCond %{REQUEST_URI} !\.less
    RewriteCond %{REQUEST_URI} !\.scss
    RewriteCond %{REQUEST_URI} !\.png
    RewriteCond %{REQUEST_URI} !\.swf
    RewriteCond %{REQUEST_URI} !\.txt
    RewriteCond %{REQUEST_URI} !\.xml
    RewriteCond %{REQUEST_URI} !\.xls
    RewriteCond %{REQUEST_URI} !\.eot
    RewriteCond %{REQUEST_URI} !\.woff
    RewriteCond %{REQUEST_URI} !\.ttf
    RewriteCond %{REQUEST_URI} !\.svg
    RewriteCond %{REQUEST_URI} !\.wmv
    RewriteCond %{REQUEST_URI} !\.avi
    RewriteCond %{REQUEST_URI} !\.mov
    RewriteCond %{REQUEST_URI} !\.mp4
    RewriteCond %{REQUEST_URI} !\.webm
    RewriteCond %{REQUEST_URI} !\.ogg
    RewriteCond %{REQUEST_URI} !docs/.*
    RewriteCond %{REQUEST_URI} !themes/.*
    RewriteRule ^ index.php [L,NC]

    ##
    ## Standard routes
    ##
    #### AAAND I MODIFIED HERE!!!
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]

</IfModule>

`

Last updated

sorentruelsen339
sorentruelsen339

I had a similar problem with windows 7, Netbeans 8 and XAMPP. After modifying the config for XAMPP and re-installing October it worked. Here is a link to how to correct the settings in XAMPP: http://www.anmsaiful.net/blog/php/enable-apache-rewrite-module.html

Søren

tomak707
tomak707

It's an important thing to mention which server softwer you're actually running. There can be the same problem (same symptoms) on nginx, which obviously doesn't use .htaccess. For those who encounter the same problem on nginx, please have a look at this thread: http://octobercms.com/forum/post/problem-installing-on-nginx-server

eduguimara1591
eduguimara1591

I'm having this problem. My mod_rewrite is enabled, I changed to "AllowOverride All" in my virtual host and I uncommented the "RewriteBase / " in my .htaccess.october. I need to put /index.php in the end of url to see the frontend style and /index.php/backend to access the backend. The problem is that my backend has no frontend(no style) at all, it's like the "http://myexample.dev" without /index.php. Can someone help me?

OctoDevel
OctoDevel

Try this is for virtual hosts if you are using apache 2.4:

<VirtualHost *:80>
    ServerAdmin web@localhost
    DocumentRoot "/home/myuser/mywebsite/"
    ServerName mywebsite.local
    ServerAlias www.mywebsite.local
    ErrorLog "logs/mywebsite.local-error_log"
    CustomLog "logs/mywebsite.local-access_log" common

    <Directory "/home/myuser/mywebsitel/">
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
    </Directory>
</VirtualHost>

Remember to set permissions to the website folder. I'm running Gnome Ubuntu 14.04 with XAMPP 1.8.4 (PHP 5.5.11 & Apache 2.4.9 & MySQL 5.6.16) and this configs are working perfectly.

eduguimara1591
eduguimara1591

Thanks OctoDevel, but it didnt work.
My apache is the 2.2.22 and this change gave me an server internal error. So, i turn back the configuration.
Here's my /etc/apache2/sites-available/default

<VirtualHost *:80>  
    ServerAdmin web@localhost  

    DocumentRoot /var/www/october/  
    ServerName october.dev  
    <Directory />  
            Options FollowSymLinks  
            AllowOverride All  
    </Directory>  
    <Directory /var/www/october/>  
            Options Indexes FollowSymLinks MultiViews  
            AllowOverride All  
            Order allow,deny  
            Allow from all  
    </Directory>
reynierpm
reynierpm

I'm running the same issue in CentOS 6.5, already tried all in this topic and without success, any other advice?

eduguimara1591
eduguimara1591

I just put "/index.php" at the end of my DocumentRoot virtual host and I don't need to call /index.php in the url anymore.

But the problem in the backend persists, no style at all.

1-20 of 34