This forum has moved to a new location and is in read-only mode. Please visit to access the new location.


Installed Oct on Homestead with nginx. Install completed and gave me my urls for navigation. The main website url is just text and looks incomplete. I get Sorry, the page you are looking for could not be found. NotFoundHttpException in compiled.php line 7670 if I try the backend. I tried setting my folders to 755 and no luck. Any ideas? Thank you for your help.

Additional information is that I an using the install wizard and I've tried the install 3 times on a PC. Also, I get the same results when installing October over Homestead on a Mac. I have zero issues with the Homestead install so I am at a loss as to why the issues with the October install. Please let me know if anyone has any suggestions. Thank you!

Last updated

Blackpig Creative
Blackpig Creative

I've not had any issues with October installs under Homestead on Mac. I've currently got 4 sites I'm developing installed.

Can you show us your Homestead.yaml file?


@Blackpig Creative... I get the same result on a Mac and a PC. I think it is something in my nginx config for location or paths that is screwing it up. I am getting the same error as seen here in these threads but I have not been able to get it working yet.

Any ideas are greatly appreciated. Thank you!

Here is my Homestead.yaml file and my nginx file...


ip: ""
memory: 2048
cpus: 1

authorize: ~/.ssh/

    - ~/.ssh/id_rsa

    - map: ~/Code
      to: /home/vagrant/Code

    - map:
      to: /home/vagrant/Code/Laravel/public

    - homestead

    - key: APP_ENV
      value: local

# blackfire:
#     - id: foo
#       token: bar


server {

    listen 80;
    root "/home/vagrant/Code/Laravel/public";

    index index.html index.htm index.php;

    charset utf-8;

    location / {
        try_files $uri $uri/ /index.php?$query_string;

    location = /favicon.ico { access_log off; log_not_found off; }
    location = /robots.txt  { access_log off; log_not_found off; }

    access_log off;
    error_log  /var/log/nginx/ error;

    sendfile off;

    client_max_body_size 100m;

    location ~ \.php$ {
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass unix:/var/run/php5-fpm.sock;
        fastcgi_index index.php;
        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_intercept_errors off;
        fastcgi_buffer_size 16k;
        fastcgi_buffers 4 16k;

    location ~ /\.ht {
        deny all;

Last updated

Blackpig Creative
Blackpig Creative

Where have you installed October? Is it in a directory under ~/Code? What url are you mapping to the October install?

Your homestead.yaml is just pointing to a Laravel install.

Try this

  • Create a new folder under /Code Called October
  • Copy the October install files to it
  • Update your homestead.yaml and add under folders:

    • map: /Code/October to: /home/vagrant/october

and under sites:

- map: october.local
  to: /home/vagrant/october
  • Edit your hosts file and add the following line october.local

  • Then run vagrant halt and vagrant provision
  • Open your browser and go to http://october.local:8000/install.php and follow the install instructions. Hopefully you should then have a fully working October install.

That's off the top of my head, I don't think I've missed any steps. As an aside I've never needed to touch my nginx config.

Last updated


@Blackpig Creative... yes... below is the path to my October install. I'll do as you suggested and reinstall October. Thank you for your help! I greatly appreciate it!


Last updated


@Blackpig Creative... Thank you so much for your help. You pointed me in the right direction and with some minor modifications I now have a fully functional instance of October. I greatly appreciate it! You rock!!!

Blackpig Creative
Blackpig Creative

Glad you got it working :)


Reposting from this thread in case this helps anyone having this issue for the first time and who just found this thread. I've included a curated list of discussion threads for similar issues at the bottom.

In my case, my Apache server's mod_rewrite was disabled. I had to reinstall my WAMP stack to get a more recent version of PHP before installing October, so my previous settings must have been lost.

This is just a matter of adding a line or uncommenting a line (usually at the bottom) of your Apache httpd.conf file like so:

LoadModule rewrite_module modules/

Just search for that line. If it's missing, add it. If it's not, uncomment it. If it's uncommented and you still have these symptoms, look to the links below for other potential problems.

Make sure to restart your apache webserver after the change or nothing will happen!

Since it took me a while to discover this solution, I figured I'd post links to all of the many discussion threads I've now have open in my browser that cover problems resulting in similar symptoms (the 1st one links to the Laravel docs that ultimately fixed my problem):

Last updated

1-8 of 8

You cannot edit posts or make replies: the forum has moved to