131

Product support

Get help in the plugin support forum.

  • Added on Jun 13, 2019
  • Current version: 1.1.2
  • Compatibility
    October CMS v3.x not tested
    October CMS v2.x use latest
    October CMS v1.x use latest
  • License: Regular / Extended
  • Created by

Categories

This plugin allows end users to binding wechat user, and login in automatic after binded.

Plugin Setting

Settings > Misc > Weixin Login set appid & secret

You can ...

  • Login with WeChat user credentials
  • Login with WeChat Open Platform website application
  • Manage WeChat User
  • Config WeChat share information

Relies on Rainlab.User

Plugin Setting

Settings > Misc > Weixin Login set the appid and secret of Offical Account and Open Platform

Authorize

Authorize in Wechat App environment

Authorize url: [your domain]/beysong/wechat/auth

Authorize with Wechat Open Platform

Authorize url: [your domain]/beysong/wechat/open

After authorize successfully, the user account will bind the Wechat User by openid If the user account has logined in. Otherwhise the bind action will execute after the user accout login. The user can login by Wechat Authorize next time.

Usage

  • install the plugin: php artisan plugin:install Beysong.Wechat or composer require beysong/wechat-plugin
  • Add the below code to any where you want
<a href="/beysong/wechat/auth?r=/redirect_url">Offical Account Login</a> or
<a href="/beysong/wechat/open?r=/redirect_url">Open Platform Login</a>

the params 'r' for binded user redirect url.

Component

  • Wechat Share
  • Found the plugin useful on 16 Mar, 2022

    Installing Plugin: beysong.wechat Executing: composer require beysong/wechat-plugin

    Using version dev-master for beysong/wechat-plugin ./composer.json has been updated Running composer update beysong/wechat-plugin --with-dependencies Loading composer repositories with package information Info from https://repo.packagist.org: #StandWithUkraine Dependency "laravel/framework" is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies. Dependency "laravel/framework" is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.Updating dependencies Your requirements could not be resolved to an installable set of packages.

    Problem 1

    • laravel/framework is locked to version v6.20.44 and an update of this package was not requested.
    • Conclusion: don't install symfony/http-foundation v5.3.2 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation 5.4.x-dev (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.3.3 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.4.0-BETA1 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.3.4 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.4.0-RC1 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v4.4.30 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.3.6 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.3.7 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v4.4.33 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.3.10 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.3.11 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v4.4.34 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.3.13 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.3.14 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v4.4.36 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.4.0 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.4.1 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v4.4.37 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.4.2 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.4.3 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v4.4.38 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.4.5 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v5.4.6 (conflict analysis result)
    • Conclusion: don't install symfony/http-foundation v4.4.39 (conflict analysis result)
    • beysong/wechat-plugin dev-master requires overtrue/laravel-socialite ~3.0 -> satisfiable by overtrue/laravel-socialite[3.0.0].
    • laravel/framework v6.20.44 requires symfony/http-kernel ^4.3.4 -> satisfiable by symfony/http-kernel[v4.4.39].
    • Root composer.json requires beysong/wechat-plugin dev-master -> satisfiable by beysong/wechat-plugin[dev-master].
    • overtrue/laravel-socialite 3.0.0 requires overtrue/socialite ~3.0 -> satisfiable by overtrue/socialite[3.0.0, ..., 3.x-dev].
    • overtrue/socialite[3.0.0, ..., 3.x-dev] require symfony/http-foundation ^5.0 -> satisfiable by symfony/http-foundation[v5.0.0-BETA1, ..., 5.4.x-dev].
    • You can only install one version of a package, so only one of these can be installed: symfony/http-foundation[v2.3.0, ..., 2.8.x-dev, v3.0.0-BETA1, ..., 3.4.x-dev, v4.0.0-BETA1, ..., 4.4.x-dev, v5.0.0-BETA1, ..., 5.4.x-dev, v6.0.0-BETA1, ..., 6.1.x-dev].
    • symfony/http-kernel v4.4.39 requires symfony/http-foundation ^4.4.30|^5.3.7 -> satisfiable by symfony/http-foundation[v4.4.30, ..., 4.4.x-dev, v5.3.7, ..., 5.4.x-dev].
    • Conclusion: don't install symfony/http-foundation 5.3.x-dev (conflict analysis result)

    Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

    Installation failed, reverting ./composer.json and ./composer.lock to their original content.

    In Process.php line 269:

    The command "'composer' 'require' 'beysong/wechat-plugin' '--update-with-dependencies'" failed.

    Exit Code: 2(Misuse of shell builtins)

    Working directory: /www/wwwroot/139.155.90.61

    Output:

    Error Output:

    Using version dev-master for beysong/wechat-plugin ./composer.json has been updated Running composer update beysong/wechat-plugin --with-dependencies Loading composer repositories with package information Info from https://repo.packagist.org: #StandWithUkraine Dependency "laravel/framework" is also a root requirement. Package has not been listed as an update argument, so keeping locked at ol d version. Use --with-all-dependencies (-W) to include root dependencies. Updating dependencies Your requirements could not be resolved to an installable set of packages.

    Problem 1
      - laravel/framework is locked to version v6.20.44 and an update of this package was not requested.
      - Conclusion: don't install symfony/http-foundation v5.3.2 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation 5.4.x-dev (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.3.3 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.4.0-BETA1 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.3.4 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.4.0-RC1 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v4.4.30 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.3.6 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.3.7 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v4.4.33 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.3.10 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.3.11 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v4.4.34 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.3.13 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.3.14 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v4.4.36 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.4.0 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.4.1 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v4.4.37 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.4.2 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.4.3 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v4.4.38 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.4.5 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v5.4.6 (conflict analysis result)
      - Conclusion: don't install symfony/http-foundation v4.4.39 (conflict analysis result)
      - beysong/wechat-plugin dev-master requires overtrue/laravel-socialite ~3.0 -> satisfiable by overtrue/laravel-socialite[3.0.0].
      - laravel/framework v6.20.44 requires symfony/http-kernel ^4.3.4 -> satisfiable by symfony/http-kernel[v4.4.39].
      - Root composer.json requires beysong/wechat-plugin dev-master -> satisfiable by beysong/wechat-plugin[dev-master].
      - overtrue/laravel-socialite 3.0.0 requires overtrue/socialite ~3.0 -> satisfiable by overtrue/socialite[3.0.0, ..., 3.x-dev].
      - overtrue/socialite[3.0.0, ..., 3.x-dev] require symfony/http-foundation ^5.0 -> satisfiable by symfony/http-foundation[v5.0.0-B

    ETA1, ..., 5.4.x-dev].

    • You can only install one version of a package, so only one of these can be installed: symfony/http-foundation[v2.3.0, ..., 2.8. x-dev, v3.0.0-BETA1, ..., 3.4.x-dev, v4.0.0-BETA1, ..., 4.4.x-dev, v5.0.0-BETA1, ..., 5.4.x-dev, v6.0.0-BETA1, ..., 6.1.x-dev].
    • symfony/http-kernel v4.4.39 requires symfony/http-foundation ^4.4.30|^5.3.7 -> satisfiable by symfony/http-foundation[v4.4.30, ..., 4.4.x-dev, v5.3.7, ..., 5.4.x-dev].
    • Conclusion: don't install symfony/http-foundation 5.3.x-dev (conflict analysis result)

      Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific vers ions.

      Installation failed, reverting ./composer.json and ./composer.lock to their original content.

  • author

    Replied on 17 Mar, 2022

    try again

1.1.2

bug fix

Mar 25, 2022

1.1.1

bug fix

Mar 25, 2022

1.1.0

add wechat share

Mar 25, 2022

1.0.10

bug fix

Mar 21, 2022

1.0.9

bug fix

Mar 17, 2022

1.0.8

bug fix

Mar 17, 2022

1.0.7

hotfix

May 19, 2021

1.0.6

test

Mar 25, 2021

1.0.5

upgrade socialite

Mar 25, 2021

1.0.4

Add wechat login by qrcode

Mar 25, 2021

1.0.3

Created table beysong_wechat_aaddvv

Jun 23, 2020

1.0.2

Created table beysong_wechat_user

Jun 12, 2019

1.0.1

Initialize plugin.

Jun 12, 2019