This forum has moved to a new location and is in read-only mode. Please visit to access the new location.


Hi! I'm working on an October CMS 2.x installation and I just got the site up and running, now I need to synchronize the project to download and install the plugins that are associated with the project. I'm running the command "php artisan project:sync" in the root directory of the project, but when I do so, some odd error messages appear to say the least:

illuminate/support[v5.6.0, ..., 5.8.x-dev] require php ^7.1.3 -> your php version (8.1.4) does not satisfy that requirement.

I find it odd as the current PHP version I'm operating with is greater than the required version. I have found a few articles around similar situations, but they address errors while issuing composer install commands, not custom October CMS commands. And while they solve their issues by adding the "--ignore-platform-reqs"-flag, the October command does not seem to support the same flag.

This is the first time I'm setting up October CMS and it's environment step-by-step at a remote computer. I'm used to work on a local XAMPP and then SFTP and use SQL backups to transfer the project to the remote server, so please pardon.

I am stuck at this point and would really appreciate some help/advice. I would also like to apologize if I'm posting this thread in the wrong category. Cheers.


Hello and welcome.

I find it odd as the current PHP version I'm operating with is greater than the required version.

Indeed it is a somewhat unusual situation for PHP, since PHP 8.1 broke compatibility with all prior versions of itself by requiring a code update. Some libraries are therefore not compatible.

In this case it seems like a plugin is trying to install the Laravel 5 support package, which is quite old and definitely not compatible with PHP 8.1

Best suggestion is to locate the plugin and remove it from your project.

1-2 of 2

You cannot edit posts or make replies: the forum has moved to