endi.linux.mint51510
endi.linux.mint51510

I recently updated the HTTP Header Policy on my Nginx website and Octobercm was unable to load framework.min.js immediately. I see the do console this message "Uncaught Error: The jQuery library is not loaded. The OctoberCMS framework cannot be initialized."

This policy that I update:

add_header Feature-Policy "geolocation 'self' https: //nickgenom.com; midi 'none'; sync-xhr 'none'; microphone 'none'; camera 'none'; magnetometer 'none'; gyroscope 'none'; fullscreen 'self' https: //nickgenom.com; payment 'self' https://nickgenom.com; ";

add_header Permissions-Policy "geolocation 'self' https://nickgenom.com; microphone 'none'; fullscreen 'self' https://nickgenom.com; payment 'self' https://nickgenom.com;";

add_header Content-Security-Policy "default-src 'self'; img-src https://sorryshutup; worker-src https://; manifest-src https: / /sorryshutup; img-src https://sorryshutup; script-src 'self' https://sorryshutup; " always;

Are these BUGS? Is there someone here to help me?

You can currently (08 October 2020) view this issue at https://nickgenom.com

Last updated

endi.linux.mint51510
endi.linux.mint51510

The problem here is slightly resolved. I updated add_header Content-Security-Policy from default-src 'self'; to base-uri 'self'; . But the message "Uncaught Error: The jQuery library is not loaded. The OctoberCMS framework cannot be initialized." keep appearing

Last updated

endi.linux.mint51510
endi.linux.mint51510

Problems that make me panic FIX SOLVED BY ME: I changed the add_header Content-Security-Policy from "base-uri 'self';"; https: // blabla1 https: // blabla2 https: // blabla3 https: // blabla3 https: // blabla4 to "base-uri 'self';";

So it just becomes this: add_header Content-Security-Policy "base-uri 'self';";

Last updated

1-3 of 3