This forum has moved to a new location and is in read-only mode. Please visit to access the new location.


Try to install on php8. After entering the license key got this:

Executing: composer require october/system october/backend october/cms october/media october/editor
Using version ^2.0 for october/system
Using version ^2.0 for october/backend
Using version ^2.0 for october/cms
Using version ^2.0 for october/media
Using version ^2.0 for october/editor
./composer.json has been updated
Running composer update october/system october/backend october/cms october/media october/editor
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - paragonie/random_compat v9.99.99 requires php ^7 -> your php version (8.0.6) does not satisfy that requirement.
    - laravel/framework v6.20.27 requires ramsey/uuid ^3.7 -> satisfiable by ramsey/uuid[3.9.3].
    - ramsey/uuid 3.9.3 requires paragonie/random_compat ^1 | ^2 | 9.99.99 -> satisfiable by paragonie/random_compat[v9.99.99].
    - laravel/framework is locked to version v6.20.27 and an update of this package was not requested.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Any idea how to fix?



Interestingly, this looks like it is an issue with Laravel itself... Did you use the create-project command before entering the license key?


daftspunk said: Did you use the create-project command before entering the license key?

Yes. Used this composer create-project october/october ddt then php artisan october:install and followed installation steps

Last updated


Hmm, I've just tested this with PHP 8.0.3 and the installation proceeds without any issue


I got this error today, more information can be found here:

This seemed to disappear after running composer update

Looks like this library is having dependency issues

1-5 of 5

You cannot edit posts or make replies: the forum has moved to