oskar.villani40843
oskar.villani40843

Hi there, I have had this error some times already and I know that it vanishes as soon as I wait for a while or restart the browser. But anyway it is annoying and drives beginners crazy. Now, with the most current version I have this problem again saying:

FatalErrorException Illuminae\Filesystem\Filesystem::getRequire(): Failed opening required '[path to installation]/storage/framework/services.php' (include_path='.')

in Filesystem.php line 84

Adding the line to .htaccess:

php_flag opcache.enable Off

as recommended in an other post still does not work reliably.

Any idea how to avoid this problem permanent? Thanks in advance!

Last updated

mjauvin
mjauvin

Try removing the /storage/framework/services.php file...

mjauvin
mjauvin

Did you contact the plugin author?

oskar.villani40843
oskar.villani40843

mjauvin said:

Did you contact the plugin author?

Hi, thank's for your advice,
did not contact any author yet, because I am not sure whether it's an error of my installation(s) or it's a bug. But it comes randomly on different occasions / installations / plugin-installs..... May be it's a cache dependent problem ...

mjauvin
mjauvin

php artisan cache:clear maybe?

oskar.villani40843
oskar.villani40843

mjauvin said:

php artisan cache:clear maybe?

Hi mjauvin!

Unfortunately clearing the cache does not work - well sometimes it does, sometimes not.

But the point is: there is no services.php in my installation causing troubles. That's crazy because sometimes it's working, sometimes not. Mostly there is no error after refreshing the page with some minutes delay (hm, I do not need that much coffee a day :) On another installation the services.php exists. But I don't know if it's ok to copy the file from one to another installation ( I don't think so). They all are for different testing purposes so far, and a lot of work is done already :/

ok - did some checks: directly after an error the service.php does not exist. After some time (seconds, minutes, I do not know exactly), the service.php file is created and October is working fine. Oh tempora, oh services!

RempadDesign
RempadDesign

oskar.villani40843 said:

Hi there, I have had this error some times already and I know that it vanishes as soon as I wait for a while or restart the browser. But anyway it is annoying and drives beginners crazy. Now, with the most current version I have this problem again saying:

FatalErrorException Illuminae\Filesystem\Filesystem::getRequire(): Failed opening required '[path to installation]/storage/framework/services.php' (include_path='.')

in Filesystem.php line 84

Hi. We faced right now the same problem. We just disabled the opcache from the Extension PHP version in use and it's all fine.

oskar.villani40843
oskar.villani40843

Finally I think I found at least one reason for this error: it's a timing issue!

Scenario is this:

  • there is no valid service.php at the moment it is required (because of changes, timeout)
  • so the service.php has to be created first by the october system
  • but this process takes too much time (for what reason ever) and the file is requested too soon
  • the system does not wait until the file is created and throws this error instead

Any experiences if this assumption could be correct?

If yes, I would like to post it to the issue tracker.

1-8 of 8