JohnKNL
JohnKNL

Hi, I had to restore a backup of OctoberCMS and everything seems to be OK, but when I click the Check for Updates button, I get an error: Empty response from the server. Same when I click Install Plugins. Any ideas? Thanks! John

JohnKNL
JohnKNL

No one??? In the meantime, the error has changed, which makes me think it's not an issue on my side. Now, the lightbox pop-up hangs for 5 seconds and then returns an HTML message:

500 Internal Server Error (I cannot copy/paste the message completely)_ The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error. More information about this error may be available in the server error log.

Time was 9:37 AM EST

Errors in my error.log are: process 8948 graceful kill fail, sending SIGKILL

JohnKNL
JohnKNL

nevermind, I rebooted my server and it seems to work now.

SLIDERWEB
SLIDERWEB

Same problem. Rebooting server not help for me. Some time ago all worked fine. Server configuration not changed. Nginx + php5fpm stack

Button code is

<a href="nojavascript...;" class="btn btn-primary oc-icon-refresh" data-control="popup" data-handler="onLoadUpdates" data-disposable>
::before
"Check for updates    "
</a>

is correct? Artisan is broken too

php artisan october:update
Updating October...
  [October\Rain\Exception\ApplicationException]
  Empty response from the server.

Exception trace:
 () at /media/HD500/hosting/sliderweb/modules/system/classes/UpdateManager.php:740
 System\Classes\UpdateManager->requestServerData() at /media/HD500/hosting/sliderweb/modules/system/classes/UpdateManager.php:224
 System\Classes\UpdateManager->requestUpdateList() at /media/HD500/hosting/sliderweb/modules/system/console/OctoberUpdate.php:68
 System\Console\OctoberUpdate->fire() at n/a:n/a
 call_user_func_array() at /media/HD500/hosting/sliderweb/vendor/laravel/framework/src/Illuminate/Container/Container.php:507
 Illuminate\Container\Container->call() at /media/HD500/hosting/sliderweb/vendor/laravel/framework/src/Illuminate/Console/Command.php:150
 Illuminate\Console\Command->execute() at /media/HD500/hosting/sliderweb/vendor/symfony/console/Command/Command.php:261
 Symfony\Component\Console\Command\Command->run() at /media/HD500/hosting/sliderweb/vendor/laravel/framework/src/Illuminate/Console/Command.php:136
 Illuminate\Console\Command->run() at /media/HD500/hosting/sliderweb/vendor/symfony/console/Application.php:843
 Symfony\Component\Console\Application->doRunCommand() at /media/HD500/hosting/sliderweb/vendor/symfony/console/Application.php:188
 Symfony\Component\Console\Application->doRun() at /media/HD500/hosting/sliderweb/vendor/symfony/console/Application.php:119
 Symfony\Component\Console\Application->run() at /media/HD500/hosting/sliderweb/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php:107
 Illuminate\Foundation\Console\Kernel->handle() at /media/HD500/hosting/sliderweb/artisan:36

No ideas how to fix that.

Last updated

alexwenzel
alexwenzel

JohnKNL said:

nevermind, I rebooted my server and it seems to work now.

worked for me +1

gray27089
david.bruenner30689
david.bruenner30689

Same problem for me. But I solved it.

For me it was because I wrote in my xdebug.ini

zend_extension=xdebug.so
xdebug.remote_enable = 1
xdebug.remote_connect_back = 1
xdebug.remote_port = 9000
xdebug.max_nesting_level = 512
xdebug.remote_autostart = 1      // added this line

but I forgot to restart the service.

So after

sudo service php7.1-fpm restart
sudo service apache2 restart

it works again.

fredericomarinho16918
fredericomarinho16918

Guys, I had the same problem, when updating the system or trying to attach some project, I was receiving an "empty response from the server". The problem was the firewall blocking the connection. All I did was open the port 80 to this URLs:

http://octobercms.com

http://gateway.octobercms.com

Voilá, everything started working fine to me! Hope this can help somebody.

Last updated

1-8 of 8