beth.nicholas65790
beth.nicholas65790

Hello. I'm very new to October and have an issue with the builder on my local development server only. What I go to save a database table created with Builder I get the following message: invalid default value for the boolean column 'status'. The allowed values are '0' and '1', or 'true' and 'false'.

When I do the same thing on the live server it works perfectly.

daftspunk
daftspunk

Hey beth, this might be related to the strictness of your database settings. You can disable strict mode by editing the file config/database.php and finding the database engine and set

'strict' => false,

I hope this helps!

beth.nicholas65790
beth.nicholas65790

Thanks @daftspunk. No luck with that I'm afraid. Could there be a setting in my local mysql config that's causing the issue? Config wise the site works perfectly on staging and live.

beth.nicholas65790
beth.nicholas65790

Thanks @daftspunk. No luck with that I'm afraid. Could there be a setting in my local mysql config that's causing the issue? Config wise the site works perfectly on staging and live.

beth.nicholas65790
beth.nicholas65790

I've disabled strict mode at the mysql level and no luck

daftspunk
daftspunk

After thinking about this, you may need to set the column as NULLABLE in the database.

In PHP migration code it should look like this as well.

->nullable()

1-6 of 6