When updating dependencies it says, Your requirements could not be resolved to an installable set of packages.
cangelis/pdf 2.1.0 requires illuminate/support 4.x -> found illuminate/support[v4.0.0-BETA2, ..., 4.2.x-dev] but these were not loaded, likely because it conflicts with another require.
cangelis/pdf 2.1.1 requires league/flysystem 0.3.* -> found league/flysystem[0.3.0, ..., 0.3.5] but the package is fixed to 1.1.3 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
studiobosco/cockpitcrm-plugin dev-6-renatio-dynamicpdf requires cangelis/pdf 2.1.* -> satisfiable by cangelis/pdf[2.1.0, 2.1.1].
Root composer.json requires studiobosco/cockpitcrm-plugin dev-6-renatio-dynamicpdf -> satisfiable by studiobosco/cockpitcrm-plugin[dev-6-renatio-dynamicpdf].