vimre
vimre

Hi Folks,

Could you please help me how could I prevent a plugin-, a third-party package- or one of its dependency to be updated since OctoberCMS v2 when I run command php artisan october:update or composer update?

I assume I should do something inside composer.json file but can't figure out the solution.
I think I was able to block a plugin update by defined the exact required version in composer.json file (I am not sure if it is the best solution though) but its dependencies still being updated for some reason.

Thanks in advance for your help!
Ps.: wish you all happy winter holidays :)

Last updated

daftspunky
daftspunky

Hey vimre,

Happy winter holidays to you too (summer here, actually). Indeed, the way to prevent a plugin from updating is to lock its version in your composer file to exactly the current version that is installed.

Show the installed version with this command:

composer show rainlab/blog-plugin

Then lock the version in composer.json, for example:

"rainlab/blog-plugin": "1.5.2",

I hope this helps!

1-2 of 2