mattckrell2409
mattckrell2409

Hi. Just found October and am loving it so far minus this one annoyance. Every time I post a contact form using either FlexiContact or OctoMail I get the following message:

Class 'GuzzleHttp\Client' not found

What's weirder about this was that it USED to work on a different machine. I've recently switched macbook pro's and synced the site with Dropbox.

I've tried running composer require "guzzlehttp/guzzle" "~4.0" to fix it and though it definitely installed Guzzle it has not fixed my problem. Please help! I really don't want to write my own plugin.

mattckrell2409
mattckrell2409

Well nevermind. Reinstalling the site seemed to fix the problem, but thats just weird. :/

Dmi3yy
Dmi3yy

After composer require "guzzlehttp/guzzle" "~4.0" http://monosnap.com/image/oScnQGcK8JPDVA4EkBRlYuPefEJ4UO

ndcisiv
ndcisiv

./composer.json has been created

Did you install OctoberCMS using the Web installer?

Dmi3yy
Dmi3yy

Yep. Now Understand %)

dylan.jacob649
dylan.jacob649

I'm having same issue. used web installer and site is hosted on a vm. I've included the October AJAX framework, but every time I submit a contact form i get a javascript alert box saying that the guzzlehttp/client cannot be found.

any ideas?

GeorgeFoto
GeorgeFoto

I am getting an alert "Class 'GuzzleHttp\Client' not found" on the register. I have used the web installer. I suppose its a dependency problem. How should I run composer in order to fix this error?

thanks

daftspunk
daftspunk

GuzzleHttp\Client is now provided by the plugin October.Drivers, please make sure you have this plugin installed.

mihilliard12611
mihilliard12611

I also have the GuzzleHttp\Client not found error. I have looked around the vendor folder and sure it is true guzzle is not installed. I have installed the Drivers by October which says it installs guzzle, but it also does not! What is wrong? Can I install guzzle manually somehow? It is important to install larvel packages when I need, unfortunately october does not seem to easily support this, or is there a way? as I would really like to adopt october as a base for projects that require a CMS. Thanks in advance.

daftspunk
daftspunk

Drivers should include Guzzle.

Reference: https://github.com/octoberrain/drivers-plugin/blob/master/composer.json#L30

Last updated

1-10 of 10