pratyushpundir6424
pratyushpundir6424

Hi guys,

Just updated my installation to build 342 and it went thru without any issues except one. The Backend Settings MenuĀ on the left now has a whitish background with white text on it. So needless to say, it's pretty hard to read anything on the menu.

Here's a screenshot -> http://prntscr.com/bbz53i

Anyone got any ideas!? Much appreciated in advance.

pxpx
pxpx

Hi, be sure to clear your cache and refresh your browser etc.

Either than, or if you were using custom CSS, remove that and see if it fixes your problem.

pratyushpundir6424
pratyushpundir6424

@pxpx - Yeah I cleared the cache already. The browser cache was cleared too. And I'm not using any custom css for the backend at all so not sure what went wrong here. Might have to write some custom css to fix this as a last resort. Might just provisions a fresh test app to see if that faces the same issue.

pratyushpundir6424
pratyushpundir6424

So a fresh installation of the same build does not have this issue. Will write back once I've resolved this.

pxpx
pxpx

No worries, assuming you have edge updates enabled as well?

pratyushpundir6424
pratyushpundir6424

Yeah I do. The latest stable is 318 I believe. I should've stuck with it. The 342 build does look pretty cool besides this issue though. Between the fresh installation and my existing project, I can spot some missing classes for sure. So that looks like the issue. Seems like the update is missing a few html files it should have updated.

Eoler
Eoler

Yeah I do. The latest stable is 318 I believe. I should've stuck with it. The 342 build does look pretty cool besides this issue though. Between the fresh installation and my existing project, I can spot some missing classes for sure. So that looks like the issue. Seems like the update is missing a few html files it should have updated.

Do the following:

  • Check for updates -> Force update
  • Settings -> Editor settings [Save & close]
  • Settings -> Customize back-end [Save & close]

Hard-refresh the browser cache (Ctrl+F5 / Cmd+R etc.) and you should be fine.

If not, it is probably something wrong with Back-end primary / accent / secondary color choice.

Last updated

pratyushpundir6424
pratyushpundir6424

@Eoler - Thanks for taking the time out. I had already tried these things but to no avail. Just tried them again and still not fixed. Also, the back-end color choices have been default since the beginning so I'm kinda sure that's not the issue.

Like I mentioned in an earlier response, the side-nav is missing the "bg-p" class which I know is what's causing the issue. The trouble is I can see the said class in the markup within the relevant partial but not when its actually inside the browser. Not sure what I'm missing here.

Eoler
Eoler

pratyushpundir6424 said: Like I mentioned in an earlier response, the side-nav is missing the "bg-p" class which I know is what's causing the issue. The trouble is I can see the said class in the markup within the relevant partial but not when its actually inside the browser. Not sure what I'm missing here.

No problems with 3 edge (344) installations here. Must be something interfering on your side. Where is .bg-p { background-color } CSS attribute coming from when you inspect it in DevTools? Its inlined in block inside backend page.

pratyushpundir6424
pratyushpundir6424

Alright so I was able to figure it out. It was a plugin I had installed that was causing the issue. Here is the plugin in question - Indikator.BackendPlus - http://octobercms.com/plugin/indikator-backend.

Removing the plugin resolves this issue. Thanks for the time you fine folks spent on this.

1-10 of 10