4nik3t
4nik3t

I have created my own custom theme for october cms and installed the rainlab user plugin.

I have created a new page name /accounts and added the user management form to it .

Similarly I added the session component in my default layout and added the conditions for displaying the login and logout depending on the user login status.

The logout functionality is working totally fine . But the issue arises when I try to login or register a new user the page only refreshes and the same registration form reappear. And when I hard refresh the page I am able to see that indeed I am logged in as It shows my profile page.

Not sure what is the exact issue . Am I missing on something.

Eoler
Eoler

freakcoder said: But the issue arises when I try to login or register a new user the page only refreshes and the same registration form reappear. And when I hard refresh the page I am able to see that indeed I am logged in as It shows my profile page.

Which version of RainLab.User? Recently it started requiring OC AJAX framework, is it included in frontend?

4nik3t
4nik3t

Eoler said:

Which version of RainLab.User? Recently it started requiring OC AJAX framework, is it included in frontend?

I am using the latest version of the user plugin 1.4.8

Last updated

4nik3t
4nik3t

I have included the following two lines in default.htm layout

{% framework extras %} {% scripts %}

Eoler
Eoler

freakcoder said: I am using the latest version of the user plugin 1.4.8

AJAX framework is a requirement from version 1.5.0 so it's probably something else... any exceptions in devtools? You'll probably have to turn on Pause on exceptions if login is redirecting to itself.

1-5 of 5